Rosso Laboratory

 
このブログで使用しているソフトウェアの略称について
VRM・・・・・・・・・鉄道模型シミュレーター(Virtual Railroad Models)現行バージョンは、VRM-NXとVRMONLINE。
TRS2019・・・・・TRAINZ RAILROAD SIMULATOR 2019
A9・・・・・・・・・A列車で行こう9 ARTDINK社製。

カレンダー

2022年
← May →
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31        

カウンター

  • 本日のアクセス  
  • 昨日のアクセス  
  • 総アクセス数      

過去ログ

ブログサービス

Powered by

teacup.ブログ
RSS
この記事にはコメントを投稿できません
コメントは新しいものから表示されます。
コメント本文中とURL欄にURLを記入すると、自動的にリンクされます。
投稿者:漆黒
只今、意図した動きとなり大満足です。本日はお仕事のお邪魔になる書込み等多々ご勘弁を(礼)。矢張り、cVssは自ら悩まないと習得出来ません本日はとても良い勉強をさせて頂きました。直走るレイアウトから脱するにはもう少し修行が必要です(ボリボリ…)本日は有難う御座いました。
投稿者:zio
まずは先のコメントに対して、

迷惑だなんてことは全くありません。色々と要望を出して貰えると、こちらでは気が付かなかったことを知ることが出来るので助かります。

さて、私も先程「貨車入換え」をcVss-PartsLayout-v114のDF50+14系でテストしてみました。VRM4ですが。

その結果、動きましたし、車両テクスチャも反転配置させれば問題なかったです。ただ、この動作は不可解です。管理されていないVRM4と管理されているVRM5の違いがココにあるかもしれません。VRM5でもテストしてみなくてはわかりませんが、今は仕事に追われているので暫くは結論が出ないだろうと思います。


次に自動発車の件ですが、先にも書いた通り、機関車のスクリプトは一応消えることになりますので、ASCセンサーから機関車に命令しても無意味のハズです。更に連結専用ASCは機関車のスクリプトにトドメをさすこと(イベントハンドラの無効化)が目的なので、ユーザー設定項目外のAutoSpeedCtrl後の動作設定を幾ら変えても動きが変わることはありません。

連結後、自動的に発車させるのであれば、編成スクリプトに「call this MethodStart」を追加してください。

//連結時メソッド
 BeginFunc MethodCouple
//貨車・客車側と一体になってイベント再設定
 KillAllEvent
 call this MethodEventStart
//入換表示標識オフ
 call this MethodTrainIndicatorOff

call this MethodStart

 EndFunc
投稿者:漆黒
先程、cVssテンプレート(cVss-PartsLayout-v114)の機廻し、EF210でセンサー(ASCセンサー(両方向・単機型・連結専用)のAutoSpeedCtrl後の動作設定を3〜5にしても自動的に発車しませんでした。ONLINEだと駄目なのかなぁ?
投稿者:漆黒
度々、ご迷惑をお掛けしまた。

素人発想はやはり簡単には行かないようですね?(反省)試しに機関車牽引列車を入れて見ましたが矢張り動きません。以前、ホッキホキで滞留していた貨車を入れ替えて牽引された事を思い出して真似したのですが(笑)
お忙しい中、ご返答下さり感謝しております。是非、ご検討して頂ければ幸いです。
投稿者:zio
なるほど貨車の入換えですか。現時点では想定していなかったです。

まず動かない理由ですが、「別線路にある貨車」にcVss編成のスクリプトが書き込まれていないからではないでしょうか?

機関車はぶつかる側になるので連結すると機関車編成は消滅します。そして、動作するスクリプトは貨車側のものになるのです。これはVRMスクリプトの連結時の仕様で変更できません。

実は機関車側のスクリプトはメモリ内に残っているようですが、消えた機関車のスクリプトを呼び出すのはNGで、強制終了が発生する場合があります。

さて「別線路にある貨車」に書き込むスクリプトですが、「機関車牽引列車」のものを使い、機関車が連結している状態の車両数に設定してやれば動くだろうと思うのですが、初期状態で機関車が付いていない状態は未だ想定していませんでしたので、車両テクスチャを使っているとおかしくなるかもしれません。テストしていないので細かいことは未だ分りませんが、今後の検討項目に入れておきます。
投稿者:漆黒
お手数をお掛けしました。本日は休みで午前中から格闘中です(汗)。スクリプトを全て「cVss」規格に変更しテスト!最初、列車が動かないので汗していたら「キー操作」で出発するんですね(笑)無事可動して大喜び!ちょっと欲を出して…。

牽引してきた貨車を切離し、別線路にある貨車を牽引しようと考え「ASC単機・連結」(動きがリアルで最高!!)で試したのですが連結したが「出発」出来ない状況です。AutoSpeedCtrl後の動作を全て試して見ましたが…う〜〜ん頭が痛くなって来ました。
投稿者:zio
こんばんは、漆黒さん。

私も「cVss」のスクリプトを改造して使うのは、かなり難易度が高いだろうと思っています。複数のオブジェクトに跨って動作していますので。・・・しかし、ただ配置して使うだけなら、そんなに難しくはないだろうと思っているのですがどうでしょう? 難しさのレベルは人によって違うので自分だけでは判断できません。それが一番難しいところです。


さて、最高速度は「SetTopSpeed」命令を使えば設定できるはずです。「VRM4CV標準化編成(機関車牽引列車)用スクリプト 機能限定版」ならば、下記のように「GetTopSpeed」の前に入れてください。

//スタート
//編成最高速度取得

SetTopSpeed 120.0

GetTopSpeed VarTopSpeed

こうすると、速度の変更は多分「cVss」の「STV速度設定センサー」や「STV速度制限解除設定センサー」がそのまま使えるはずです。「ASC速度設定センサー」は、あの時点から変わっているので元に戻さないと使えないはずですが。
投稿者:漆黒
今晩はzioさん。cVssはちょっと小生にはハードルが高いか(笑)ここ毎日、「機廻し改造版(New レイアウト作成)」で遊んでおります。少々お尋ねしたい件が御座いまして…

「編成の最高速度」を変更出来ないものか?又「途中でセンサーにて速度を減速」その後「設定速度に復帰」など出来たらなぁ〜と思いお尋ねする次第で御座います。又御手隙にでもお付き合い下され。
teacup.ブログ “AutoPage”
AutoPage最新お知らせ